windows 7 cannot logon as administrator

Solved
  1. tham

    tham New Member

    Joined:
    Aug 4, 2010
    Posts:
    2
    Likes Received:
    0
    Local time:
    15:39
    My System
    Loading...

    just bought a new laptop computer with windows 7 home premium
    I logon as a user
    i want to install my software
    windows requests to logon as administrator
    but nowhere is the administrator logon icon to see, not when i start nor when I do `switch user`

    following a suggestion on a forum I did:
    1.Open the command prompt with elevated privileges by clicking the Start orb, All Programs, Accessories, right-click Command Prompt and then select Run as administrator.
    2.Type net user administrator /active:yes and then press Enter.
    3. restart

    NO CHANGE, no icon, unable to logon
     
  2. Amtech

    Amtech Well-Known Member Tech Member Elite Member

    Joined:
    Nov 9, 2008
    Posts:
    2,694
    Likes Received:
    178
    Local time:
    14:39
    My System
    Loading...

    If you click Start > Run > click OK and type in control userpasswords2 > click OK

    What comes up?

    And if yours is the only account then it must have Administrator privileges :eek:Z

    If you got this from HP or a similar company you can try restoring the laptop to its default. This will delete any files you may have put on the laptop.

    But it sounds like you haven't done much with this laptop yet. If you want to restore it to its default settings usually there is an option to press Esc immediately after restarting the laptop.

    One of the startup options there should be System Recovery or something similar.

    If there is more than one user then one of those is an Administrator; not the one you keep logging onto.
     
  3. tham

    tham New Member

    Joined:
    Aug 4, 2010
    Posts:
    2
    Likes Received:
    0
    Local time:
    15:39
    My System
    Loading...

    I lost hours on this one, but found the solution.
    The advice you find on forums is missing a crucial line.

    Go to start, all programs, accessories.
    you will see "command prompt"
    rightclick on it
    choose "runs as administrator"
    Type net user administrator /active:yes and then press Enter.
    restart

    The important missing part is that your cursor/prompt should be in the root-directory.
    You should see C:\>| AND NOT something like C:\>whatever>whatever>|

    If it is not: type CD.. (CD dot dot) and do a return. Repeat this until you see C:\>|
    Once there you type net user administrator /active:yes

    Lo and behold: it worked like magic
     
  4. Amtech

    Amtech Well-Known Member Tech Member Elite Member

    Joined:
    Nov 9, 2008
    Posts:
    2,694
    Likes Received:
    178
    Local time:
    14:39
    My System
    Loading...

    Looks like you solved this one yourself. I'll mark this as Solved.