AODDriver4.0 service failed

Solved
  1. vinyc3

    vinyc3 New Member Bronze Member

    Joined:
    Apr 26, 2011
    Posts:
    65
    Likes Received:
    1
    Local time:
    01:44
    My System
    Loading...

    Cheers for the thread fix-up.

    I had already performed a clean install but tried the installation guide posted for arguments sake.
    Before reinstalling the driver I tested the internet browser which worked well and my mouse pointer didn't jitter in the corner of the screen. No game exe's opened though and windows aero is not fixed.
    I have reinstalled the 11.4 AMD drivers and now the internet browser works and games will open and run. BUT, aero is not fixed, the mouse still jitters and the overall performance of teh computer is slower.
     
  2. DCiAdmin

    DCiAdmin Well-Known Member

    Joined:
    Sep 30, 2008
    Posts:
    1,907
    Likes Received:
    274
    Local time:
    08:44
    My System
    Loading...

    lol - I"m with you on the need for black coffee ;)

    What if you uninstall Catalyst? Perhaps try an earlier version even?
     
  3. vinyc3

    vinyc3 New Member Bronze Member

    Joined:
    Apr 26, 2011
    Posts:
    65
    Likes Received:
    1
    Local time:
    01:44
    My System
    Loading...

    I tried the driver on a CD included with the graphics card which is intended for the 6870 and 6850 but to no avail (Catalyst Control Center 2010.0930.2237.38732).

    The problem has not changed much.
    *Aero is changed to basic
    *Games play but take several minutes to load and gameplay is extremely choppy and laggy in single player.
    *Computer seems generally slower

    Only positive is the mouse isn't jittering in the corner anymore.

    Personally I feel I should reinstall windows 7 on a reformatted hard drive as I may have changed something important while playing around. And this wasn't always like this, something triggered it. argh
     
  4. DCiAdmin

    DCiAdmin Well-Known Member

    Joined:
    Sep 30, 2008
    Posts:
    1,907
    Likes Received:
    274
    Local time:
    08:44
    My System
    Loading...

    What if you run without Catalyst Control Center and only use the driver?
     
  5. vinyc3

    vinyc3 New Member Bronze Member

    Joined:
    Apr 26, 2011
    Posts:
    65
    Likes Received:
    1
    Local time:
    01:44
    My System
    Loading...

    Ok I caught the culprit in action!!
    I did yet another clean install of CCC 11.4 and the VGA drivers. Everything went back to normal; the games played well, the computer ran well and the Aero transparency was back. Then I noticed Windows Updater down on the taskbar and found it was trying to download an Ati 6870 video card driver.
    For some reason windows thinks I do not have the latest drivers and was installing a second on top of the one I had installed.

    SO, THE FIX (if windows is installing another driver):
    *Follow the PCHF instructions to do a clean install of video drivers, posted earlier on this thread.
    *Turn internet OFF
    *Open Windows Update in start menu
    *Go to 'Change settings' and change "install updates automatically" to "download updates but let me choose..."
    *Turn internet ON
    *In windows update go 'back' and click 'check for updates'.
    *If windows finds a video driver right click it and select 'Hide'
    *DONE

    Also I did a bit of research and the 'laggy mouse in the corner' is a known AMD driver problem that has no fix yet.

    Please mark this thread as SOLVED :)
    Thank you for all the help I will continue to use this site!!
     
    vger likes this.
  6. JMH

    JMH Guest

    Joined:
    Aug 29, 2010
    Posts:
    88
    Likes Received:
    0
    Local time:
    02:44
    My System
    Loading...

    Terrific news...
    Thank you for reporting back.
    Safe surfing.



    This thread is now marked as Solved and has been Closed.

    If the problem re-occurs, please start a new thread.
    If for any reason it has any bearing on your original thread then please state this and a member of staff will supply the link to the original post.
     
  7. DCiAdmin

    DCiAdmin Well-Known Member

    Joined:
    Sep 30, 2008
    Posts:
    1,907
    Likes Received:
    274
    Local time:
    08:44
    My System
    Loading...

    Brilliant, Vinyc! Glad you stuck with us :) Look forward to seeing you around!
     
Similar Threads
Forum Title Date
PC Internal Hardware Windows service plug and play won't start error 2 Oct 25, 2012
PC Internal Hardware services.exe error, comp keeps restarting Dec 30, 2006