Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Mark as Solved
Results 1 to 2 of 2
  1. #1


    Hi I'm new to the forum and I hope this is the right place. I build this system last fall. It's my second one. Everything went fine until one day, it wouldn't turn on -- or rather it would cycle on and off (a few seconds on, a few seconds off) repeatedly until power was cut. I am very much a beginner when it comes to this stuff.

    Here is the guts of the thing:
    Motherboard: ASRock P67 Extreme
    Graphics card: MSI R5770 Hawk
    Memory: 2x G.Skill Sniper 4GB
    Hard Drive: Western Digital Black 500GB
    Processor: Intel Core i5-2500k
    Power Supply: Corsair TX-850

    I appreciate any replies. Thank guys.
      My System SpecsSystem Spec

  2. #2

    Replace power supply.

    Also check connections, and make sure you used standoffs before putting the motherboard in the case.

    And Ranger Dag says "problem Sol-ved."
      My System SpecsSystem Spec



Note   Please note
        When your issue is fixed please remember to thank those that helped you and mark the thread as solved.
Similar Threads
Thread Forum
I Just Didn't Know Windows XP
VMWare: Sorry we didn't mean to allow Leopard Tech News
New Post Didn't Take! Introduce Yourself
CES: What Microsoft's Ballmer didn't say Tech News
About Us
PC Help Forum is an independent website that provides free advice and technical support for members and guests. All trademarks mentioned are the property of their respective owners. PCHelpForum.com is not responsible for views, comments, content or external links posted by members.

© Designer Media Ltd
All times are GMT -6. The time now is 10:43.
Find Us
Twitter Facebook

PC Help Forum